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Before we start - a brief overview of your ClassPad and its storage.

A ClassPad has memory divided into four parts, which together provide 24Mb of storage: main
memory, a data storage area called the USB Flash Drive and an eActivity storage area which together
are called FLASH ROM, and RAM used to execute the required calculations. The ability to understand
the movement of data between these areas and to transfer such data to and from external storage
devices will enhance your experience in utilising your ClassPad in teaching environments.
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Computer

Storage Area ClassPad Drive
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Work in Progress 2014 Page 2 of 13



Commonly required tasks

Backup of your ClassPad.
Return to your main menu by tapping the Menu key m on the icon
panel.

From the Menu, tap ‘MENU’ on the top bar to reveal a drop-down
list of options as shown:

Select ‘Save As’

You will now be presented with a view of your FLASH memory
directory, with folders identified by small black triangles which
expand to reveal folder contents. A default file name is given as
Default.vcp.

Perhaps overwrite the name to something more meaningful to you,
then tap ‘Save’. In the examples that follow, the standard adopted is
the word ‘backup’ followed by the date, such as
backup06052014.vcp .

This backup now exists in your CLASSPAD Flash memory, from where
it might be transferred to a connected computer and hence safely
stored or migrated onto another CLASSPAD.

vcp files are a CASIO proprietary file format, where vcp is an
acronym for Virtual ClassPad.
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Note that you can create your own folders within FLASH memory, and indeed subfolders if you wish.

Work in Progress 2014

Page 3 of 13



Restoring your CLASSPAD from a previously taken backup.

File Search View

MENU £
If the required backup is already on your zE:n
CLASSPAD (as would be the case from the Save As :

Touch Panel Alignment

above instructions), simply select Open

from the dropdown list of options from the =
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can see a file directory of your CLASSPAD

flash storage area, including any folders you -

backup07092013.vcp |

backup07092013. vcp

have defined. Sequence ’D‘"‘Eﬂ Financial
-— @l - ]
Open
Typically your backups will be in your top level folder (the default) as File Search View
illustrated in the example above, but if you have many files in your & |dag
storage area you may have organised them into subfolders. In the \_(Root Directory)
. . . . b Add-in A
illustrative picture alongside, subfolders have been used. Tap the folder » Auto;:,,,:rts
name to expand it — in this case, the folder will be the Backups folder. b Backups
p Geometry Data
» Memory Data
» Picture
Select the required backup from which you would like to restore, and
then tap ‘Open’.
You will now be invited to completely replace the current contents with - m

the backup data, or to merge (overwrite where necessary). The
overwrite option may be useful for the mass importation of new
activities and data files from a teacher calculator to a student calculator
— this will be discussed later.

Work in Progress 2014

File Search View
i | i
\Backups

Eachpl]E[lﬁzm 4.ycp i
backup28032014.vcp
backup30032014.vcp

backup06052014. vcp

m

Page 4 of 13



Access to your FLASH memory from a computer

3 Link Setup
Prior to using the following instructions, it is worth checking [“’ B | b=
that you are currently set up to connect via USB: Current Setting:
USB cable
Use the Communication Menu icon = c?,m,t,r‘,_ Wakeup Enabled
(on the alternate set of menu icons). -
Data Communication Lo
£ LInI-c Communication
= | He Open Setup Menu W Cable Type
i USB cable v [
If the Current Setting Current Setting: [s ol | l
is not USB cable and USB cable [ ::Eszf]u ';n) | ]
ps v
Wakeup enabled,
P Walkeup Enabled Wakeup Enable
select ‘Open Setup’ [ on | 'l
from the Setup
Menu.
You will be
presented with the
Communication Set ‘ | Cancel ‘ ‘ Default
screen alongside,
from which you need
to select ‘USB Cable’
as the Cable Type.
Data Communication M pata Communication -

The Cable Type must be set to USB Cable to communicate with a computer, and 3-pin for
communication between calculators.
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Connect your CLASSPAD to your computer by inserting the mini-

USB.

When presented with the Status screen shown alongside (which
will appear automatically on your calculator if the earlier settings

were made), select ‘USB Flash’ — this option presents your

CLASSPAD to your computer effectively as a USB drive does when

inserted.

You should accept the Autoplay invitation on your computer to
open a folder to view the contents of the inserted device, if asked.

You will now be able to m —
= » Computer » Removable Disk (D) »

view the ‘FLASH
storage’ section of your
CLASSPAD (note in the
example below that
24.1 Mb of secondary
storage is available).
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Screen Receiver
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Cancel
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Organize v [ Open  Sharewith v New folder
Xt Favorites ] Neme Date modified Type Size
B Desktop I Add-in Apps 6/05/2014 2:15 PM File folder
18 Downloads ). Autolmport 1/12/20111:00 AM  File folder
=l Recent Places V] |. Backups 1/12/20111:00 AM  File folder
%7 Dropbox ). Geometry Data 6/05/2014 2:14 PM File folder
& OneDrive 1. Memory Data 6/05/2014 2:15 PM File folder
I Picture 1/12/2011 1:00 AM File folder
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&, 0sDisk (C) - "-'““ u*
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|, Add-in Apps i S
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% T_Drive (\ .
8 1_Drve Qyeach Type: Removable Disk
@ 5
MNetwork File system: FAT
l l Backups Date modified: 1/12/2011 1:00 AM . USEd space: 37936’256 bytes 3'?5 MB
File folder
e [ Free space: 21,364,736 bytes  20.3MB
Capadity: 25,300,992 bytes 24.1ME
Drive D:
[ Ok ] [ Cancel Apply
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Now that you have a viewing window of your FLASH storage memory on your computer, you can
transfer files around and maintain their organisation. Examples of this might be:

e to copy all folders from your CLASSPAD ClassPad
FLASH storage onto the computer for

. Main Memor
external backup security v

e to reorganise the folders on your
CLASSPAD FLASH storage and their
contents using the computer eActivity Area

Flash ROM

e To copy externally sourced backups onto Computer
ClassPad Drive

your CLASSPAD FLASH storage from Storage Area
(USB Flash Drive) *TT—1"

where they can be manually restored

By moving files from your CLASSPAD onto your computer, you can create external copies of your
CLASSPAD contents, either complete backups (.vcp files) or individual variables (.xcp files — where
xcp is an acronym for eXported ClassPad).

Your CLASSPAD can work with up to 200 files per folder, and can use up to 3 levels of folder
hierarchy. This is easiest to maintain from your computer, but be mindful of the fact that your
computer will have no such limitations on folder sizes and levels, so keep your folder structure
simple with no more than three levels.

Once files exported from your CLASSPAD are available to your computer, they can be shared — you
might envisage emailing a backup copy (or individual eActivities or Geometry constructions) to
others in order that they might load their CLASSPAD with similar information to your own, or placing
it in a shared network location where they could subsequently be loaded onto other CLASSPADs.

The technique described above, where the entire contents of one CLASSPAD might be used to
populate another teacher or student CLASSPAD. Note that at the point when the restore is
performed, you can choose to ‘Merge’ rather than overwrite — see page 4 of this document.
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Restoring your CLASSPAD from a previously taken backup stored on a
computer.

After having connected your CLASSPAD to a computer, copy the required backup from the computer
back into the CLASSPAD Flash storage — you can drag & drop them or copy & paste them (including
folder hierarchies) easily.

Clearly if a central teacher computer was to be used to propagate a CLASSPAD image to many
students, one method might be to backup the required teacher CLASSPAD, then use the above
method to place the .vcp image onto the student calculators from which they can manually open
the backup to restore, either in its entirety or merging using the Overwrite option.

An alternate quicker method is to copy the required backup into the Autoimport folder. As soon as
the file is copied into this folder on the computer, the link is disconnected and the CLASSPAD
automatically imports the image. Once it is done, the backup .vcp file used is moved from the
Autoimport folder to a folder called SAVE-F — it will create this folder if it does not already exist. The
advantage of this method is that students need not be tasked with the job of selecting a backup
image and opening it. The disadvantage is that the Overwrite option is unavailable, and all pre-
existing data will be lost.
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Movement of CLASSPAD elements

Rather than backing up and restoring entire images, it is possible to migrate individual CLASSPAD

elements, such as eActivities and variables (examples include expressions, lists, matrices, functions,

geometry data and spreadsheet data).

These must be selected individually for backup by initially exporting them from your CLASSPAD Main

Memory into FLASH storage, where they will appear as a .xcp file format in the folder of your choice.

This export is performed from the System

gﬁ System

main Menu option.

Under the Storage tab shown at right, choose the type of
element you wish to export —Variables or eActivities.

The selection will then list the folders on your CLASSPAD, and a
tally of qualifying elements ( in the example alongside, it shows
‘19Vars’).

All CLASSPADs will have a Main folder displayed. Potentially
there may be a Library folder or User-defined folders also
listed.

You may select the whole folder by ticking the box alongside.

Alternately, if you wish to choose only some elements from the
folder, then tap on the folder name and it will expand to
provide a list of all qualifying elements in that folder from
which you may select individual elements to Export.

Once you tap the ‘Export’ icon, a list of available folders is
presented, from which you must select the destination folder
for the export (into which the created .xcp file(s) will be
placed).

One .xcp file will be created for each exported element.

The name of each .xcp file will be the individual element name
followed by a data type, such as f-(Function) or Pig_Pen-
(Geometry).
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. i E=R =
.@@U e * Computer » Removable Disk (D:) » Search Re.. 0
Organize « Share with + MNew folder == ~ [l @
<% Favorites = [ Mame . Date modified Type Size
Ml Desktop . Add-in Apps 6/05/2014 2:15PM  File folder
& Downloads .. Autelmport 1/12/2011 1:00 AM File folder
=l Recent Place .. Backups 1/12/2011 1:00 AM File folder
%+ Dropbox .. Geometry Data 6/05/2014 2:14 PM File folder
& OneDrive .. Memaory Data 6/05/2014 215 PM  File folder
. Picture 1/12/2011 1:00 AM File folder
- Libraries A-(Matrix) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
@ Documents Area-(Function) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
J? Music autosave-(Mem) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
[ Pictures B-{Matrix) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
E Videos | f-(Function) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
3 g-(Function) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
1M Computer h-(Function) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
3—" 0SDisk (C:) Pig_Pen-(Geometry) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
== Removable [ testss-(Mem) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
. Add-in Ap. v-(Function) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
- Autolmpo y-(Function) 1/12/2011 1:00 AM CASIO ClassPad Manager Exported ClassPad Data File
Barliinr

The exported files will now appear in .xcp format in the folder view on your connected computer, as
illustrated above. They may now be transferred to your computer, in the same method as before by
connecting the USB cable and selecting the USB Flash option on your CLASSPAD.

Once any such .xcp files have been transferred to a computer, they are fully transportable to any
other CLASSPAD, as are any vcp files created from backup functions (see earlier for backup creation
and transfer to a computer) . Simply copy them into a connected CLASSPAD folder in its USB Flash
memory, then select the Communication option from the Main Menu.

Select ‘View Storage & Import’, and tick each element you wish to import prior to tapping the Import
icon. You will then be asked to nominate your destination of choice — typically you will choose
‘main’.

If an element you have nominated to import already exists in the chosen destination folder, you will
be prompted for a decision to overwrite.
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Equivalent processes on CLASSPAD Manager.

* 1'{®] ClassPad Managy
Your CLASSPAD Manager uses a ‘Home Folder’ on your v Vew er
computer to replicate the USB Flash memory area of the o &

New...

handheld. This is defined during the software installation. H Open..

- Save
If you are unsure of its location, choose ‘File -> Change g smens.

Change Home Folder..

Home folder’ from your CLASSPAD Manager session.

This folder can be used in an equivalent manner to that
described above for a connected handheld. You may
import .xcp variables and eActivities from it, or export
equivalent information into it for backup or transfer to
other devices.

Note that the concept of a .vcp backup does not exist for
CLASSPAD Manager — but is unnecessary anyway.
Individual data types may be transferred as above.

— e ]

Resizable Mode
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LCD Window A

File »
Recent Documents »

Print

Paste Special -

Capture Screen

Always on top
Minimize

Zoom »

About ClassPad Manager...
Search ClassPad Manual

Search ClassPad Manager Manual
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ClassPad to CLASSPAD exchange of information.

Using the 3-pin (smaller cable with an end similar to a set of headphones) two CLASSPAD devices can
communicate with each other.

Each calculator must be set to a Cable Type of 3pin from the ‘Setup’ menu under the
Communication menu icon.

On each calculator proceed to the Link menu area.

Set the ClassPad receiving information to Receive, either by using the icon Heo '
or via the ‘Link -> Receive’ dropdown menu. . .

Set the ClassPad sending information to Transmit, either by using the icon
or via the ‘Link -> Transmit’ dropdown menu.

| =, |
B

Firmly plug the cable into the receiving device, and then the sending device. The sending device will
automatically present a list of main memory folders for you to transmit. You can select items by
tapping the tick box alongside a folder, or by expanding the folder by tapping its name, and then
ticking individual elements within the folder. Tap the transmit icon when all elements to be
transferred have been selected.
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Other file types.

Addins (such as Algy2 or Physium) have a file type of c2a. These can be transferred from your
computer to your CLASSPAD (having connected your device using the mini-USB cable as before) by
copying the c2a file into the root directory on your CLASSPAD.

Pictures to be used as background images to graphing windows have a file type of c2p. Such pictures
must be generated using CASIO’s Picture Conversion Engine software, available by contacting Casio
Education Division (URL http://www.casio.edu.shriro.com.au/app/contact us.php ) if you are a

Prime Schools PLUS member. Once your pictues have been converted to the proprietary c2p format,
they can be moved onto your CLASSPAD in the same manner as other CLASSPAD elements.

Importing Elements from CLASSPAD 330 series.

Pre-existing elements on a Classpad 330, such as programs or eActivities, can be exported as .xcp
files from the ClassPad 330 and then can be imported into a ClassPad 400 series in the same manner
as elements exported from a ClassPad 400. Note, however, that the screens of the two machines
have a different resolution — any elements placed at particular positions on the screen of a 330
model may not work to your liking on the 400 model.
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